DJclassifieds

More
5 years 1 week ago #6215 by Valberg
Valberg created the topic: DJclassifieds
Hi,

I've edited the classifieds_button.jpg in the header_mod module. I know editing the image should have any effect. I have unpublished some modules, but all classifieds modules shoukld be enabled now.

When i click the classifieds "button" on the frontend i getL
Notice: Trying to get property of non-object in /home/sites/update2day.net/public_html/components/com_djclassifieds/views/items/tmpl/default_cat.php on line 227 Fatal error: Call to a member function get() on a non-object in /home/sites/update2day.net/public_html/components/com_djclassifieds/views/items/tmpl/default_cat.php on line 227

From line 227 i see:
if($active_m->params->get('show_page_heading','1')){
echo '<h1 class="main_cat_title">';
if($active_m->params->get('page_title','')){
echo $active_m->params->get('page_title','');
}else{
echo $active_m->title;
}
echo '</h1>';
}
}
}

The link used in the "button":
href="index.php?option=com_djclassifieds&view=items&layout=blog&cid=0&Itemid=501

Could i get some help identifying why i get this error? Itemid=501 is the previous classifieds menu that i have renamed and made some edits to. I have re-enabled show page and title header but still the same.

I assume its something in the menu item i miss.

Thanks in advance

Tore

Please Log in or Create an account to join the conversation.

More
5 years 6 days ago #6218 by artur
artur replied the topic: DJclassifieds
Hello,
Please contact with support via tickt :
joomla-monster.com/contact/
Add site URL (to page with the problem), login/password to Joomla nad FTP server.
This will help with locating the problem.

Best Regards.

Please Log in or Create an account to join the conversation.

More
5 years 6 days ago #6222 by Valberg
Valberg replied the topic: DJclassifieds
Thanks

I figured out the problem: I changed the itemid in the href link for the classifieds "button" to the menu item i moved the plugin to. (duh)

I also had another issue today, just in case someone else encounter the same.

- When ever i made a module change, publish/unpublish etc. It took up to 15 mins for the change to display. Cache disabled, time synced with server.
- New articles show up immediately on "Category Blog" menu item, but not in "feed" modules on "Home"

I had some issues before with this that was related to the configuration file permission. But then i realized i just had managed to enable url-rewriting. And it turned out top be related to that,

After a bit of googling:
This was solved by un-commenting "RewriteBase /" in .htaccess

Tore

Please Log in or Create an account to join the conversation.

Time to create page: 0.241 seconds

INDICO S.C.

ul. Wałowa 10/3, 84-200 Wejherowo, registered in Centralna Ewidencja i Informacja o Działalnosci Gospodarczej
NIP/VATID: PL5882424318

Copyright © 2009-2019 Joomla-Monster.com All rights reserved.

Joomla-Monster.com and this site is not affiliated with or endorsed by The Joomla! Project™. Any products and services provided through this site are not supported or warrantied by The Joomla! Project or Open Source Matters, Inc. Use of the Joomla!® name, symbol, logo and related trademarks is permitted under a limited license granted by Open Source Matters, Inc.