Responsiveness? issue when "page class" changed

More
4 years 2 months ago #8031 by fredousek
fredousek created the topic: Responsiveness? issue when "page class" changed
Hi all,

I have an issue with responsive behaviour. Let me explain:

I assigned to the menu item K2 (category) menu item type. Then, I put page class "hidden-phone" so that it is not shown when displayed on the phone. So far it works. It means K2 category is displayed always expect on mobile. Even if I click on one of the article, the article is shown according the configuration.

Then, I created a new module to substitute this K2 category when displaying on the mobile. This module is K2 content type. Here I put Module class suffix - visible-phone. Again, it works - shown on mobile.

BUT, when I click on one of the displayed item, the article is not opened on mobile. Nothing happens. Actually, it seems that the article is opened, but not shown because of the class suffix (visible-phone) applied on the menu item described above.

Can you please advise whether it relates to the template or if you know where the problem could be?

You can login to the site. I restored the pwd used in one of my previous ticket. If you don't have it, let me know.

Thank you very much,

Regards,
David

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #8032 by fredousek
fredousek replied the topic: Responsiveness? issue when "page class" changed
I just removed hidden-phone class from here and it seems working now properly:
I assigned to the menu item K2 (category) menu item type. Then, I put page class "hidden-phone" so that it is not shown when displayed on the phone. So far it works. It means K2 category is displayed always expect on mobile. Even if I click on one of the article, the article is shown according the configuration.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #8033 by fredousek
fredousek replied the topic: Responsiveness? issue when "page class" changed
Oups, unfortunately, problem not solved.

Any idea why the k2 item is not shown when configured as explained above, please? I see the item's name even in the address path, but not visible :-(

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #8035 by artur
artur replied the topic: Responsiveness? issue when "page class" changed
Hello,
Component and module uses different menu items :
www.projektaci.cz/item/252-micromanageme...ak-tymove-spoluprace
www.projektaci.cz/component/k2/item/272-...ak-tymove-spoluprace

As I can see everything should working well.

If you open article in component (252) and resize page, article will disappear because of class 'hidden-phone', but if you reload home page and open article from module (272) article will be visible.

Please Log in or Create an account to join the conversation.

Time to create page: 0.247 seconds

INDICO S.C.

ul. Wałowa 10/3, 84-200 Wejherowo, registered in Centralna Ewidencja i Informacja o Działalnosci Gospodarczej
NIP/VATID: PL5882424318

Copyright © 2009-2019 Joomla-Monster.com All rights reserved.

Joomla-Monster.com and this site is not affiliated with or endorsed by The Joomla! Project™. Any products and services provided through this site are not supported or warrantied by The Joomla! Project or Open Source Matters, Inc. Use of the Joomla!® name, symbol, logo and related trademarks is permitted under a limited license granted by Open Source Matters, Inc.