× Support for Joomla 2.5 templates is discontinued. This forum category is read-only.

Menu link not work

More
6 years 11 months ago #2331 by dataservice2005
dataservice2005 created the topic: Menu link not work
Hello, i have buyed a DJ-Education template, have installed using Quickstart and it install the Joomla 1.7.2 version and the complete template (modules, component ... )
When i push on the menu link in the frontpage none is working, an example link:

www.xx-xxxx.it/web/index.php/template-features

answer: No input file specified.

This menu is in the Main menu and positioned on template under header, orange menu bar (none menu link is working)

I tried to open a menu link on the School resource left side position, the link was it:

www.xx-xxxx.it/web/index.php/submenu

answer: No input file specified.

All the menu link answer so, but why ??

I tried also to made a new Menu voice but the same problem, answer: No input file specified.

How can i resolve this problem ??


Waiting suggest and help from you.

Thank you. Bye.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #2333 by izabela
izabela replied the topic: Re: Menu link not work
You're using frindly urls, why now? I mean during building the website? It does not make any sense.
Standard urls gives important information about itemids, that you can't control if you are using frindly urls now.

What is more, did you check if you need to enable .htaccess file on your server when using friendly urls?
Site -> Global Configuration -> SEO settings
This may be the reason of the problem.


As for the menu, I mean our dj-menu module that should be used with that template, I am not able to check what you've done until you provide the correct site url to let me see that.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #2335 by dataservice2005
dataservice2005 replied the topic: Re: Menu link not work
Hello, not have changed anything in the SEO settings, the installation put Friendly URLs on Yes, i have now changed SEO settings all voices NO and the menu link working now.
Now on the server there is the htaccess.txt and not .htaccess file, but before to put Friendly URLs Off (No) i had tried to use .htaccess file but the links not worked.

Ok for the moment, i incoming to made my modify and at the end i'll see again the problem to SEO settings.

Thank you, Bye

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #2337 by izabela
izabela replied the topic: Re: Menu link not work
OK, great!

ps. read the message in the cloud that appears on mouse hover on "Use URL rewriting" parameter.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.247 seconds

INDICO S.C.

ul. Wałowa 10/3, 84-200 Wejherowo, registered in Centralna Ewidencja i Informacja o Działalnosci Gospodarczej
NIP/VATID: PL5882424318

Copyright © 2009-2019 Joomla-Monster.com All rights reserved.

Joomla-Monster.com and this site is not affiliated with or endorsed by The Joomla! Project™. Any products and services provided through this site are not supported or warrantied by The Joomla! Project or Open Source Matters, Inc. Use of the Joomla!® name, symbol, logo and related trademarks is permitted under a limited license granted by Open Source Matters, Inc.